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his month, we’ll continue to
T look at great tools for removing

backgrounds from complex
images. Last month we covered the
Background Eraser, which is
designed to separate hard-edged
objects form backgrounds. This go-
round we’ll figure out the
Image>Extract command, a new
feature in Adobe Photoshop 5.5.

The Extract Command

The Extract command is designed
to remove backgrounds on soft-edged
objects such as hair and objects in
motion. Before you jump in, you
should be aware that the Extract
command doesn’t work when your
image is in one the following color
modes: Bitmap, Duotone, Indexed
Color, or Multichannel. If your image
is in one of those modes, be sure to
change the mode before attempting
to remove the background.

If you choose Image>Extract (or
opt/alt-cmd/ctrl-X), you’ll find a
whole dialog box full of options. It
might take us a while to wade
through all of them, so before we
dig too deep, let me fill you in on
what Extract is looking for. This
command needs three pieces of
information before removing the
background: which areas should be
thrown away; which areas should
be kept; and which areas contain a
combination of both.
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Blue means keep, green means maybe,
and no color means delete.

In the image above, the areas
covered with blue will be left
untouched and the areas with no
color will be deleted. Photoshop
will analyze the green-covered
areas to determine which should be
kept and which deleted. It will base
its decision on how similar the
highlighted areas are to the areas
that are being deleted or kept.

Highlight the Edge

Your job is to use the Highlighter
tool (upper left in the dialog box) to
cover the areas that contain a
combination of background and
subject (where the edge of your
object fades into the background).
As you start using the Highlighter,
green stuff will be overlaid onto
your image. If this color is hard to
see (perhaps your document contains
lots of green), you can change the
highlighting color in the Highlight
pop-up menu (upper right). You can
either pick a predefined color (Red,

Green, or Blue), or choose Custom
to choose from a color picker.
When highlighting the edge of
your object, avoid highlighting areas
you really want to keep, or else
Photoshop might decide to remove
some of that area. If there’s any
“overspray,” it is better to get it
on the areas you want Photoshop
to delete.
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It's better to “overspray” on the
background than the subject.

The brush size you are using is
determined by the setting found in
at the upper right of the dialog. It’s
not often that | need to type a number
there because there are faster
methods. You can use the bracket
keys (“1” and “[*) to increase or
decrease the brush size in increments
of one. Or you could simply click
on the number and use the up and
down arrow keys to do the same
thing, and then you’d also have the
option of holding the shift key to
increase or decrease the number in
increments of 10. You can also click



on the triangle to the right of the
number to select a size between 1
and 999 pixels by dragging across
the slider that appears.

Be sure to change the size of
your brush based on how far out
the edge of the object fades. Areas
that contain hard edges should
contain little highlighting (and be
sure not to get too much overspray
on the subject), but in areas that
gradually fade out, you’ll need to
cover the whole fade area for
Photoshop to perform well.

If it’s taking you too long to
highlight the entire edge of the
object, hold the shift key and click
in multiple areas (don’t drag) and
Photoshop will connect the “dots”
with straight lines, which can really
speed things up. If you hold shift
while you drag, it will restrict your
movement to horizontal or vertical.
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Shift-click to create straight line
segments.

Unlike other features in Photo-
shop, the Highlighter tool does not
have an Undo capacity. If you mess
up in an area, you’ll grab the Eraser
tool to remove the excess high-
lighting. If you're a keyboard short-
cut junkie, just hold the opt/alt key
while you paint and the Highlighter
will erase rather than paint. The
same thing works with the Eraser:
Holding opt/alt turns it into a
highlighter for as long as you hold
down the key.

If you’re working on a large
image, you might need to zoom in
to better see what you’re doing.
The most obvious way to do this is

to use the Zoom tool to click on
your image, or opt/alt click with it
to zoom out. This method means |
have to look away from my image,
so I'd rather use keyboard
shortcuts. You can access the Zoom
tool by holding the cmd/ctrl key
and the spacebar at the same time.
You could also hold down
cmd/ctrl and type plus (+) or
minus (-) to zoom in or out.

Occasionally, these commands
don’t work. If that happens, hold
down the spacebar, click anywhere
on your image, then try the command
again—I bet they’ll work. If you
use the Zoom tool, you’ll find it
much faster to click-and-drag to
indicate the area where you’d like
to zoom in, instead of clicking
multiple times.

When you’ve zoomed in, you
can use the Hand tool to scroll
around in the image, or hold down
the spacebar to temporarily access
that tool. Finally, if you’d like to
zoom back out on the image,
double-click the Zoom tool (not on
your image, but on the tool itself)
to return to a 100% view.

Fill the “Keepers”

You’re going to end up using the
Paintbucket tool to fill the area you
want to keep. When you do, Photo-
shop will ignore your image and
instead concentrate on the high-
lighting you created. The paint
will spread out until it hits the
highlighting or the edge of the
document. It’s important
to highlight all around the image
or the fill will flow into areas you
wish to keep.

When the highlighting is done,
grab the Paintbucket tool and click
on the area of your image that
you’d like to keep. If you click in
the wrong place (an area you really
wanted to delete), just click in the
area a second time; Photoshop will
remove the fill from that spot. You

might need to fill multiple areas if
the first click didn’t cover all of the
areas you intended to keep.

Click with the Paintbucket tool to fill the
areas you'd like to keep.

Preview the Extraction

Once you have completed the
highlight and the fill, Photoshop
has the information it needs to extract
the image. You’ll notice that the OK
button is grayed-out (unavailable).
Photoshop assumes that you’ll fine-
tune the highlighting, so you'll
have to click the Preview button
before you can click OK.

Photoshop will preview the
areas that will be removed by
replacing them with a checker-
board pattern.
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The checkerboard represents an area
that will be deleted.

At this stage, it’s hard to see
problem areas when you’re looking
at the checkerboard. To get around
this, choose a contrasting color
from the Show pop-up menu
(lower right in the dialog box).
Custom will present a standard
color picker, which will make it
much easier to see problem areas.
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A contrasting color makes it much
easier to see problems around the edge.

To touch-up problem areas,
zoom into the spot, then turn on
the Highlight checkbox to see
where you placed the highlighting.
Remember that the highlight
should cover all the areas that
contain a combination of
background and subject. If you
notice a spot where you messed up,
use the Eraser or Highlighter tool
to fix that area.

Turn on the Show Highlight checkbox to
check for improper highlighting.

To bring up a new preview,
you’ll need to use the Paintbucket
tool again to make the Preview
available again—whenever you use
the Highlight or Eraser the fill
disappears. The Show pop-up
menu will allow you to switch
between viewing the extracted and
original image which can help you
figure out if you’ve correctly
highlighted an area.

There’s a remedy if you’ve been
a bit sloppy with your highlighting.
Maybe you’ve covered the whole
shebang in a subject and background
area instead of merely the transition
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portion. You can go back and erase
the highlight from the areas that
really should be removed, where it
really isn’t a fade out. That can be
difficult when your image is
covered with highlighting. You can
turn off the Highlight checkbox
and use the Eraser, but the second
you click the mouse, the highlight
will show up again.

If you get into a situation where
your highlighting is right on but
the transition between the subject
and the deleted area just doesn’t
look right, try increasing the
Smooth setting and re-preview the
image. Smooth usually increases
the amount of fade-out and
therefore gives a softer edge.

Left: Smooth=0, Right: Smooth=100.

When you’re playing with the
highlight and fill, you might be
tempted to click OK to see how the
image would look with the rest of
the layers in your image—don’t do
it! If you click OK and then try to
return to the Extract dialog box,
you’ll have to start over from scratch
because the feature will not remember
where your highlighting was. This
would be a huge pain, so make
sure the edge of the object looks
just right before clicking the OK.

Extract

After you click OK, why does
Photoshop delete the background
instead of giving you a selection?
Because there’s more going on than
background removal. Photoshop is
also tying to perform edge spill

cleanup where the colors used in
the background contaminated the
colors of the subject. There might
be shifts in the colors that show up
in the fade-out areas to make sure
no hint of the old background
shows up.

Right: The original background color
spills into the edge. Left: The spill has
been replaced by the new background.

If you don’t want the colors in
your image to change, then
duplicate the layer before using the
Extract command. This way you
can move the duplicate above the
extracted version and then choose
Group with Previous from the
Layer menu to avoid color changes.
The duplicate will show up only
where there is information on the
layer below, which results in
replacing the colors underneath.

Left: The color changes can help the
image blend with a new background.
Right: W ithout the edge cleanup,
you might see hints of the old

background color .

If you'd rather get a selection,
duplicate the layer before using the
Extract command. Once you’ve
removed the background, then
cmd/ctrl-click on the extracted



image and you’ll have a selection.
Now you can throw away the
extracted version and you will
have the original with a selection.

Eyedropper for Thin Stuff

This Extract thing might sound
really nice, but what if the subject
of your photo is not a large object?
Maybe you’re trying to select
power lines, lightning, fireworks, a
sketch, or branches. Do you really
want to take the time to do all that
highlighting? You’d have to
highlight the transition between the
object and the background, leaving
enough space to use the Paintbucket
to fill the area you want to keep.
That would take forever! Adobe
thought of just that when they
were creating the Extract command.

For thin, same-colored objects, use the
Force Foreground setting.

When you open the Extract
dialog, you’ll notice the Force
Foreground checkbox. When you
turn that on, the Paintbucket tool is
grayed-out and the Eyedropper
becomes available: Now, you won’t
need to leave room to fill with the
Paintbucket. Instead, you can
highlight the entire area you want
to keep and the fade-out areas.
Then you can use the Eyedropper
tool to pick a single color to
represent the stuff you want to
keep. You'll see a sample of the
color you’ve chosen right below the
Force Foreground checkbox. As
you might expect, this works best
on single-colored, thin objects.

When the highlighting is complete
and you’ve picked a color to repre-

sent the subject, you are welcome
to press the Preview button. Most
likely you’ll need to adjust the
Smooth setting until the edge looks
right.

If the image looks somewhat
transparent after smoothing, you
can simply duplicate the layer
three or four times to build up
density.

Left: Result of extraction, Right:  After
duplicating the layer four times.

Load Highlight

You’d think we’ve about
covered the Extract command.
After all, the only option left is a
pop-up menu called Load
Highlight. Well, that little pop-up
menu opens up a whole new
world of possibilities, so hold on
to your hat as we venture deeper
into the Extract command.

Remember when you were high-
lighting the edge of your object—
you couldn’t choose undo—you had
to type “1” what felt like a billion
times to get a noticeable change in
your brush size—and how extract
wouldn’t remember where you high-
lighted if you tried it a second time,
etc? Well, we can overcome all
those limitations and make the
whole process much more powerful
if we start to use QuickMask mode
instead of using the Highlighter tool.

QuickMask

Before going into the Extract
dialog box, try typing “Q” and
then painting with the Pencil tool.
(If nothing shows up, make sure
the foreground color is black.)
Doesn’t that look a lot like the
highlighting, except in red?

QuickMask mode should look just like
the highlighting in the Extract
command, except it defaults to red

instead of green.

You've just turned on the
QuickMask mode and you’re not
stuck with that red. At the bottom
of the tool palette are two icons
right next to each other, directly
below the foreground and back-
ground colors. The icon on the
right is QuickMask mode and the
other is Normal mode. Double-
click on the QuickMask icon and
change the color to whatever you'd
like to use for highlighting. Notice
that you also have control over the
opacity of the highlighting.
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Double-click the Quick-Mask icon to
change its color and opacity

Now start painting around the
image with the Pencil tool. Stay away
from the Paintbrush and Airbrush
because they won’t deliver the hard
edges you need. To change the size,
use the same keyboard command
you used in the Extract dialog, “[**
and “],” but notice that you get a
larger change. No more typing “ 1]
111111111 to only slightly
enlarge your brush. And now you
even have multiple undo’s! Type
opt/alt-cmd/ctrl-Z and you should
be able to access up to 20 undo’s!
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If you want to remove some of
the highlight, switch to the Eraser
tool or try this interesting feature:
Double-click on the Pencil tool to
access its Options palette. Turn on
the Auto Erase checkbox. Now you’ll
either delete or paint, depending
on where you press the mouse
button. Press it while you’re on top
of an area that doesn’t contain
highlighting and you’ll highlight
until you release the mouse button.
Click on an area that already contains
highlighting and Auto Erase
should delete until you release the
mouse button. Pretty cool, huh?
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Turn on the Auto Erase checkbox to allow
the Pencil tool to both paint and erase.

If you end up creating a “rim”
that needs to be filled, you'll be
tempted to just paint back and
forth until it fills in. But there’s a
faster way. If you’ve created a
closed shape you want to fill, why
not use the Paintbucket tool? Just
make sure your foreground color is
black and it will ignore the image
and spread out until it butts up
against your highlighting.

Use the Paintbucket tool to fill enclosed
areas of the highlighting.

Let’s try a slightly different way
of creating a highlight. Type “Q” to
turn off QuickMask mode, then
Select>Deselect to get rid of the
selection you made (that’s what
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QuickMask really does). This time,
grab the Lasso tool and make a
crude selection just outside the
edge of the object, in the spot
where you’d want the highlighting
to stop.

Now type “Q” to turn on
QuickMask, then make a second
selection just within the object to
represent where the highlighting
should start. Hit delete and see if it
fills with color. If not, option/alt-
delete instead. Now you should see
the exact opposite of where you
wanted the highlighting to be, so
choose Image>Adjust>Invert, or
type cmd/ctrl-1. That should put
the highlighting in the correct spot.
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With QuickMask Mode, you can create
your highlighting using the Lasso tool.

Now that the highlighting is
where you want it, let’s load that
information into the Extract dialog
box. First, turn off QuickMask by
typing “Q,” then choose Select>
Save Selection and give the
highlighted image a memorable
name.

Now choose Image>Extract and
click on the Load Highlight pop-up
menu. You should see the name
you just typed. Choose that name
and you should see the highlighting
appear on top of the image. Now
you can use the Paintbucket tool to
fill the area you want to keep, and
press the Preview button.

If the Paintbucket tool is not
available, that’s because you have
the Force Foreground checkbox
turned on. You can use either the
Eyedropper (Force Foreground) or
the Paintbucket, but not both.

Don’t be afraid to experiment
with this QuickMask idea. Try
typing some text while QuickMask
is turned on and then delete away
some of the center to make room
for the Fill tool to give the type a
cool distressed look. See what
happens if you use different
Smooth settings on various parts of
the image by starting with a
selection to limit where the Extract
command can delete from your
image.

Before we conclude our tour of
the Extract command, let me share
some keyboard shortcuts that can
speed things up:

B=Switch to Brush tool

K=Switch to Paintbucket tool

E=Switch to Eraser tool

I=Switch to Eyedropper tool

Z=Switch to Zoom tool

H=Switch to Hand tool

Option/alt-Cancel=Reset dialog
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