Using the Background Eraser
in Photoshop 5.5

t my seminars, one of the
Amost common complaints |

hear is that people are having
a heck of a time making selections
in complex images. If you are
having similar pains, then you'll be
glad to know that Photoshop 5.5
has two features that will ease your
struggle, the Background Eraser
tool and the Extract command.

Much Ado About Something

Before we jump in, you should
know that each of these tools has a
specific purpose. The Background
Eraser, which is grouped with the
normal Eraser tool in your Tool
palette (the eraser with scissors
icon), was designed for removing
the background from hard-edged
objects. The Extract command
(Image>Extract) was designed for
soft edges, like hair or objects in
motion. If you use these tools for
something they are not designed
for, you most likely will be
disappointed.

There is so much to explore with
these features that | couldn’t do
both of them justice in one article.
So, this month’s installment covers
the Background Eraser, and next
month’s Instant Expert will take a
look at the Extract command. (In
this issue, Martin Evening explores the
Extract command in a tutorial
beginning on page 28.)
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Double-click on the Background
Eraser to access its Options palette.

Background Eraser

The Background Eraser presents
you with a circular cursor with a
crosshair in the middle. When you
click on an image, Photoshop
looks at the color under the
crosshair and deletes everything
within the circle that is similar to
that color. Then, as you drag the
cursor, Photoshop keeps a
constant eye on what is under the
crosshair and deletes areas of
similar color that fall within the
circular cursor.

The top of this image shows the
original and the bottom shows the area
the Background Eraser would remove.

The Tolerance setting determines
the range of colors Photoshop will
delete based on the color under the
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Tolerance settings from top to bottom:
1%, 10%, 20%, 30%, 40%, 50%, 60%,
70%, 80%, 90%, 100%.



crosshair. Low Tolerance settings
limit how far Photoshop will
stray from the color you are
clicking on, while high settings
tell Photoshop to delete a broader
range of colors. You can use a
different Tolerance setting each
time you click, so you’re not stuck
with a single setting for the entire
image. If the background you are
deleting is very similar to the
subject in one area, try a lower
Tolerance setting and then use
higher settings for the rest of the
image. You can quickly change the
Tolerance setting by using the
keyboard number keys (30=30%,
25=25%, etc.).

When you are moving around
the edge of an object, make
sure the crosshair never touches
the area you want to keep;
otherwise Photoshop will delete
that area as well.
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Keep the crosshair away from the
areas you would like to keep;
otherwise the Background Eraser
might delete more than you intended.

To get an accurate edge, be sure to
keep the crosshair as close to the
edge of the object as possible.

Go Easy on Yourself

The earlier you think about remov-
ing the background, the easier it is
to remove. If you haven’t yet taken
the photo, you can use a simple
backdrop that contrasts with the
subject. If the photo has already

been taken, then perform color
correction on it before attempting to
remove the background. Before
applying color correction, unwanted
color casts can make the subject and
background appear to be similar in
color and contrast, making it more
difficult to remove the background.
You can also make things easier
by first using the Lasso tool to make
a loose selection around the object,
choosing Select>Inverse, and then
pressing the delete key. This will
remove the bulk of the back-
ground, leaving only the more
complicated areas to clean up
with the Background Eraser.

Save the Background Eraser for the
more difficult parts of the image.

When you get to very small
enclosed areas, don’t feel like you
have to click and drag to remove
the background. Just click on an
area to tell Photoshop to look at a
single pixel under the crosshair and
determine what to delete from
within the circle.

If you notice a one-pixel-wide
residue showing up around your
image, don’t worry about it for
now. We’ll use a special technique
to remove those halos after you’ve
gotten rid of the majority of the
background. For now, simply try to
get rid of blobs that are larger than
a single pixel.

If you can’t wait to see what the
edge will look like later in the process,
choose Layer>Matting>Defringe
and use a setting of 1. If that doesn’t
get rid of the edge, then choose Edit>
Undo and continue to use the Back-
ground Eraser to remove the edge.
Use the Defringe command only as
a preview, then choose Undo when

finished; the Defringe tool is the
most effective after the entire
background has been deleted.
Applying it over and over again
will harm your image.

The Defringe command should be
able to remove single-pixel halos from
the edge of your image.

At times it is awfully hard to see
what’s really happening because the
checkerboard pattern that indicates
a transparent area is too busy.
Before | even start using the
Background Eraser tool, | create a
new layer and fill it with a color
that contrasts with the object I’'m
working on (like florescent green).
Then | move the duplicate layer
below my image and start using
the Background Eraser. That makes
it much easier to see if there is any
leftover residue.

It’s difficult to see residue when the
checkerboard is behind your image,
so replace it with a contrasting color.

The Background Eraser uses the
currently active brush from the
Brushes palette. You can quickly
switch the active brush by using the
bracket keys (] and [) to get the next
or previous brush.

History Brush to the Rescue
| often find myself dragging the
Background Eraser over a long
span before releasing the mouse
button, which occasionally causes
problems. If | mess up after I've
made it three-quarters of the way
around my image, the Undo
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command will undo the entire
stroke when | wanted to fix only a
small area. When this happens, |
use the History Brush to bring just
a portion of the image back to its
original state.

There are times, however, when
the History Brush is not available.
That usually happens when you’ve
changed either the image size or
the color mode. If that’s the case,
just open the History palette and
click to the left of the history state
you’d like to paint with (in the area
that looks like an indent). Most likely,
you will want to use the bottom-most
state that isn’t called History Brush.
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When the History Brush is not

available, click to the left of the last

non-Background Eraser step to paint
with that version of your image.

That allows the History brush to
paint with what your image looked
like before using the Background
Eraser. When you're finished with
the History Brush, you can quickly
get back to the last Eraser tool you
used by pressing the Y key.

Use the History Brush to bring back areas
that should not have been deleted.
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If you find that the Background
Eraser is deleting too much of the
image, you can either lower the
Tolerance setting or turn on the
Protect Foreground checkbox.
With this checkbox turned on,
Photoshop wiill try to not delete areas
that are similar to the foreground
color. If you opt/alt-click when
using the Background Eraser, you
will change your foreground color
to the color you clicked on, which
will protect it from being deleted.

Sampling the Goods

Now let’s find out why you’d
want to mess with the Sampling
pop-up menu in the Options
palette (double-click the Back-
ground Eraser to access the
Options palette). There are three
options: Continuous, Once, and
Background Swatch. The Con-
tinuous setting constantly checks
the color under the crosshair while
you move the cursor. This is good
for images where the background
varies in color.

7

Continuous sampling is best for deleting
areas that contain a variety of colors.

The Once setting is useful with
solid-color backgrounds. With this
setting you have to be careful only
when you first click the mouse
button. Then, as long as you keep

The Once setting can be helpful with
simple backgrounds.

the mouse button down, Photoshop
will only pay attention to the color
you clicked on. But stay on your
toes—Photoshop will take a fresh
look under the crosshair if you
accidentally click again.

If you don’t want to worry
about releasing the mouse button,
use the Background Swatch setting.
You can opt/alt-click to change the
foreground color, and press the X
key to switch that color to the back-
ground. Now it won’t matter how
many times you click on your image
because Photoshop will ignore
what’s under the crosshair and pay
attention to only the current
background color when deciding
what to delete. The Background
Swatch setting is effective on
extremely simple images, such as
text on a solid-color background.
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The Background Swatch setting is effec-
tive on extremely simple images, such
as text on a solid-color background.

Contiguously Continuous?
When you’ve figured out the
Sampling setting that works best
on your image, you can experiment
with the other pop-up menu in the
Background Eraser Options palette.
It decides whether Photoshop will
delete areas that touch each other,
or if it will leap over areas to get
to non-touching areas. The
Contiguous setting forces the
Background Eraser to delete only
areas that touch each other. For
example, it wouldn’t be able to
jump to the center of the letter “O”
unless you moved the crosshair
into that area. This setting is great
when areas of the object you want
to keep are similar, but not
touching the background.



The Discontiguous setting tells
Photoshop to jump over areas
(which will not be deleted) to find
areas that are similar to the color
under the crosshair. It’s ideal for
deleting the background from
complex objects such as trees;
otherwise, you’d have to get the
crosshair between every branch of
the tree without ever touching a
single branch—no thanks!

Use the Discontiguous setting to leap
across areas you do not want to delete.

Occasionally you might notice
that the Background Eraser partially
deletes an area that you’d rather it
left alone. That tells you Photoshop
thinks the area should slowly fade
into the background like a blurry
edge. You can prevent this by using
the Find Edges setting, which makes
Photoshop think you are working
on a crisp-edged object and
minimizes the areas that Photoshop
makes partially transparent. Like
the Contiguous setting, Find Edges
can only delete areas that touch
each other.

The Find Edges setting will limit the areas
that become partially transparent.

If you have areas that should be
only partially deleted because they
have soft edges, make sure to use a
soft-edged brush and stay away
from the Find Edges setting. Hard-
edged brushes often create stair-

stepping in partially transparent
areas. You can minimize this by
double-clicking on the brush (in the
Brushes palette) and lowering both
the Hardness and Spacing settings.

Hard-edged brushes produce a stair-
stepped look in partially transparent areas.

Soft-edged brushes are more
appropriate for semi-transparent areas.

When you’re using the Back-
ground Eraser, you might notice
that the edge between the areas
you have deleted and the areas you
haven’t finished erasing looks like
a series of touching circles. This
happens when you use a relatively
large brush. As you move your
cursor, the crosshair touches
transparent areas that have nothing
that can be deleted. When the
crosshair hits image data, it

Don't worry if your outline looks like
circles bumping into each other;
concentrate on the edge of your object.

resumes deleting and causes the
repeating circles to appear.

There’s nothing to fret about,
unless it is also happening in the
transition between the area that
should be deleted and the object
you are working on. That’s when
you should switch to a softer
brush, which will make the stair
stepping less obvious.

Convert to Layer Mask

When you’ve done as much as
you can with the Background
Eraser, you may want to convert
the result into a layer mask for
further refinement: cmd/ctrl-click
on the name of the layer in the
Layers palette, then Layer>Add
Layer Mask>Reveal Selection, and
click on the left-most thumbnail in the
Layers palette. Replace the contents
of that layer with your original image
so you can easily bring areas back by
choosing Edit>Fill and setting the
Use pop-up menu to History. If
History is grayed out, you’ve
changed the size or color mode of
your image since you opened it,
and you’ll have to use the History
Brush technique mentioned earlier.
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Fill with History so you can bring back
areas using the layer mask.

Now that the erasing has been
converted into a layer mask, you
can enhance the results. Option/
alt-click on the layer mask thumb-
nail in the Layers palette to make
the layer mask visible. The areas
that were not completely erased
will show up as white or gray in
the layer mask.
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It's easy to see the problem areas once
the background has been converted
into a layer mask.

If you see mostly dark shades of
gray surrounding the image, opt/
alt-click the layer mask again to make
the image visible. Choose Image>
Adjust>Levels and pull in the upper
left slider until you no longer
notice residue in the background.
Then adjust the middle slider to
fine-tune the transition between the
transparent and opaque areas.
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Levels can help to clean up the gray
specks that appear after using the
Background Eraser.

To clean up messy leftover bits,
opt/alt-click on the layer mask again,
change the foreground color to black,
and use the standard painting tools.
If you see mostly noise, choose
Filter>Noise>Median and use a low
setting to smooth out the image.

After cleaning up the obvious
areas, opt/alt-click on the layer
mask again to view the main image
and continue touching up. Black
makes areas disappear and white
makes them show up. You might
find it useful to quickly exchange
the foreground and background
colors by pressing the X key.

When the background is clean,
you can further refine the transition
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between object and background by
painting with the Blur tool on the
layer mask.

Semi-transparent areas often
appear noisy.

Use the Blur tool to smooth out
these areas.

Clean Up the Edge

Once you have tweaked the
layer mask until the image looks
almost perfect, you can drag the
layer mask thumbnail to the Trash
and click Apply to delete the
background permanently.
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Apply the layer mask; otherwise the
Defringe command will not be
available.

As a final step, you may select
the Layer>Matting>Defringe
command and use a low setting
(such as 1) to ensure there isn’t a
single-pixel rim that resembles the
previous background color. This
command works only after the
layer mask has been removed, so
don’t try it earlier in the process

unless you decide to not use a layer

mask at all.
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You should be able use settings
of 1 or 2.

You will find that the Back-
ground Eraser does a less than
perfect job on areas that fade out,
such as objects in motion. In those
instances, the Image>Extract
command will save the day. Use
the Background Eraser for its
intended purpose (working with
hard-edged areas) and hold off on
those soft-edged areas until next
month when we’ll tackle the
Extract command. I’'ll even show
you how to use it to clean up some
of the mess left behind after using
the Background Eraser (stuff we
cleaned up manually using a
layer mask).

While you’re waiting for your
next issue of PEI, check out all the
free tips | provide on my Web site
at www.digitalmastery.com. <

Ben Willmore is the author of Official
Adobe Photoshop 5 Studio
Techniques (Adobe Press), and
founder of Digital Mastery, a training
and consulting group in Boulder,
Colorado. Find out if Ben is coming to
your area with his “Master Photoshop
In 3 Days” seminar by visiting
www.digitalmastery.com.



