galore, as we began to see in

“Part I: Photoshop’s Color
Modes” (PEI February 2000). In
Part I, we became acquainted with the
various color systems, such as CMYK,
RGB, HSB, Lab, and hexadecimal,
and we looked at the reasons we
would choose one color system
over another. We rummaged
through the Color Picker dialog
box and discussed the importance
of using it properly.

Now we’ll move on to the Color
Picker palette, the Eyedropper tool,
the Swatches palette, and the Info
palette (this plain looking palette is
more useful than you think!). Finally,
we’ll look at some great ways to use
Photoshop’s measurement tools.

P hotoshop has color picking tools

Color Picker Palette

A compact version of the Color
Picker is available in the Color palette
(Window>Show Color). In this
palette, you can choose a color system
from the side menu, then move a
slider, enter a number, or click on
the color bar at the bottom of the
palette to adjust the colors of each
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The Color palette is a smaller version of
Photoshop’s Color Picker dialog box.
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channel. You can also change your
background color by clicking on it
within this palette (the one with
the double border will change).

In fact, you can even change the
color bar: Choose one of the bottom
choices from the side menu (right
mouse button in Windows), ctrl-click
on the gradient or shift-click on it to
cycle through the choices. RGB
Spectrum will display the colors
reproducible in RGB mode; CMYK
Spectrum will display the toned-
down colors that are reproducible
in CMYK mode; the Grayscale Ramp
will show only grays; and Current
Colors will show the gradient
between the current foreground and
background colors. This palette has
some real advantages over the
Color Picker dialog box.

When performing color correc-
tion in CMYK mode, it is important
to use the correct amount of cyan
ink in neutral gray areas. To do this,
set the palette to the CMYK sliders,
use the Grayscale Ramp, and then
click and drag across the gradient at
the bottom of the palette. Now you
can determine exactly how much
cyan is needed for any shade of
gray. You can even do that while
you are performing color correction
in the Curves dialog box!

The grayscale slider is a nice fea-
ture of the Color palette, which the
Color Picker dialog lacks. This control
is essential when working on a gray-
scale image, channel, or layer mask
or performing color correction.

Choose Grayscale Sliders to specify
specific shades of gray.

If you create Web graphics, you'll
want to choose Web Color Sliders
(Version 5.5 only). Photoshop will
make the sliders snap to the tick
marks on the sliders, which is
where all the Web-safe colors are. If
you don’t want a Web-safe color,
just hold the option key as you drag
the sliders. If you want to use the
same color in an HTML program,
choose Copy Color as HTML to
supply the code. Then you can
paste it into an HTML generation
program like Adobe GoL.ive. You
can also choose Make Ramp Web
Safe from the side menu to display
only Web-safe colors within the
bottom color bar.
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Choose Web Color Sliders and
Make Ramp Web Safe to get the
most Web-friendly color picker you
have ever seen.




One more color palette goodie
before we move on: With default
settings, the colors that appear in
the sliders change as you move the
sliders, to show you what would
happen to a color if you moved one
of the sliders to a specific position.
At that point, you can simply look
at the color in the slider to see what
you’d get. You can turn off this
feature if you'd like, and then the
sliders will indicate only the color
you are controlling (R, G, B or C, M,
Y, K). I never turn it off, but you
can, by choosing File>Preferences>
General, then turning off the
Dynamic Color Sliders checkbox.

cursor), press the caps lock key to
bring up a crosshair cursor.
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The Sample Size setting determines how
many pixels Photoshop will average
when using the Eyedropper tool.
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Left: Dynamic Sliders option turned on.
Right: Dynamic Sliders turned off.

Eyedropper Tool

There is still one more method of
choosing a color—the Eyedropper
tool. With the Eyedropper, you just
click anywhere within any open
image and the foreground color will
change to the color you click on.
You could also hold down the
option key to change the back-
ground color. When you use the
Eyedropper, it usually looks at only
the exact pixel you click on, but you
can change it so that it takes an
average of a 3x3- or 5x5-pixel area.
This change is made by changing
the settings in the Options palette,
or control-clicking (right mouse
button in Windows) and choosing
from a similar menu.

I usually have the Eyedropper
set to 3x3 pixels to average in any
noise or imperfection in the image.
Otherwise, | might accidentally get a
whisker color when what | wanted
to select was a flesh tone. If you have
trouble figuring out exactly what
part of the image you are clicking
on (because you get an Eyedropper

The black boxes above indicate how
many pixels Photoshop would average
when using the Eyedropper tool.

Swatches Palette

Now that you’re completely
armed when it comes to choosing
colors, let’s figure out how to store the
colors you like for quick retrieval.
That’s the purpose of the Swatches
palette. If it’s not already open on
your screen, choose Window>Show
Swatches. Click on any of the open
spaces at the bottom of the palette
to add the current foreground color
to the palette. If you use up all the
spots, resize the palette to make
room for more by pulling on the
lower right corner. You can also hold
down the shift key and click on one
of the existing colors to replace it,
or hold down the command/control
(cmd/ctrl) key and click on a color
to remove it from the palette.

No, you can’t drag them around
to rearrange them, though | wish you
could. When you have assembled
the colors you would like to use,
click on a swatch to change the fore-
ground color. You can also opt/alt-
click to change the background
color. If you've played around until
the colors are all mixed up, choose
Reset Swatches from the side menu

of the palette to return to the
default colors. Be careful—if other
people use your computer, they
might quickly wipe out all of those
colors you so carefully picked. Once
your colors are nicely organized
within the Swatches palette, choose
Save Swatches from the side menu
SO you can retrieve them any time
with the Load Swatches command.
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Use the Swatches palette to store
commonly used colors.

You're not stuck creating your
own colors—Photoshop comes with
a bunch of preset swatches. You just
have to know how to get to them.
Click on the side menu and choose
Load Swatches if you want to add
to what'’s already in the palette, or
click Replace Swatches to get rid of
the current ones. You should see a
standard Open dialog box. Navigate
your hard drive to the Photoshop>
Goodies>Color Swatches folder,
where you will find the presets. Let’s
see what we have to choose from.
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Choose Replace Swatches from the
side menu of the Swatches palette to
access Photoshop’s preset swatches.

The Macintosh OS and the system
palette files are identical. They are
used mainly in the design of
interface elements, such as the icons
that appear on your hard drive.

VisiBone, Web Hues, and Web
Spectrum are all ways to organize
the Web-safe colors we discussed.
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Clockwise from top left: VisiBone2,
Web Spectrum, Web Hues.

Adobe didn’t stop there. You can
access extra goodies that are not
loaded on your hard drive with the
default install. Go grab the CD-
ROM that Photoshop came on and
plunk it into your computer. You'll
notice another Goodies folder on
the disc that contains even more
Web-safe swatch presets. These
were created by Lynda Weinman
and they look like this:
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Clockwise from upper left: full
saturated range, 216 browser-safe
colors, 216 by luminosity.

Lynda was crazy enough to create

more than 30 versions of these palettes

—if you enjoy them, be sure to check

out her Web site: www.lynda.com.
Let’s get back to the normal
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presets. The Windows palette is
used in the same way as the Mac
palette, and has even more preset
palettes available if you know where
to look. In Version 5.5, Adobe moved
some of the swatches files from the
Color Swatches folder to another
file. Inside the Goodies folder, notice
the folder called Adobe Photoshop
Only. Inside that folder is another one
called Color Swatches, where you'll
find another list of preset palettes.
All of these choices are special (except
Web Colors). When you open one
and move your cursor over the
swatches, the name of the Swatches
palette will change to display the
name of that particular color. These
are the same choices you had when
we were in the custom version of
the Color Picker dialog box.
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The Photoshop>Goodies>Adobe
Photoshop Only>Color Swatches
folder contains custom color swatches.
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When using a custom setting, the
name of the swatches palette changes
to indicate the color your cursor is over.

Now that you know how to get
an array of colors in the Swatches
palette, you might want to use it all
the time. You can even use the colors
in the Swatches palette when you
are in a dialog box. For instance,
create a new layer, paint in it, and
then choose Layer>Effects>Bevel
and Emboss. You should notice a
small square to the right of the
highlight settings. Click on this
square to bring up a Color Picker.
When it’s open, move your cursor
to the Swatches palette and click on
one of them (you can even click on
your image instead). If the
Swatches palette is collapsed at the
bottom of your screen to conserve
space, you won’t be able to open it
without choosing its name from the
Window menu (double-clicking the
palette’s name earns you only a
beep from Photoshop).

Info Palette

Now you should know your
way around the Swatches palette,
but there’s even more to know about
describing colors. If you've already
used a color in your image, then you
might want to use the Info palette
to see what it’s made of. Open the
Info palette (Window>Show Info)
to see the composition of the color
directly under your cursor.
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The Info palette describes the color
that is currently under your cursor.

With default settings, the Info
palette is smart enough to know the
color mode your image is in, and it



will make the upper left readout
reflect that mode. Just because you
happen to be working in RGB
mode at the time, it doesn’t mean
you want Photoshop to define your
colors that way. You can always
change the mode by clicking on the
little Eyedropper icon next to any of
the readouts in the Info palette and
choosing from a number of
methods for defining a color.
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Click on the Eyedropper icon to
change the method Photoshop uses
to describe colors.

Some of these choices are less
than obvious. Actual Color means
the readout will reflect the color
mode your image is in. There are
some special ones at the bottom of
the menu, too. Total Ink will add up
the percentages of cyan, magenta,
yellow, and black to indicate the
total amount of ink coverage in an
area, which is useful if the job will
be printed on a press. The kind of
paper you use dictates how much
ink you can apply without causing
drying problems.

So, for example, if a friend gives
me an image in CMYK mode, |
could use this setting to find out if
he exceeded the recommended
percentages of each ink for the kind
of paper I’'m printing it on. You can
find out this kind of information if
you have a good relationship with
your printing company.

Some RGB colors can’t be repro-
duced using CMYK inks. Since you
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can’t change a color using the Info
palette, Adobe decided not to
include the same type of warning
(that triangle thingie) that you find in
the Color Picker. Instead, they added
exclamation marks (!) next to the
CMYK numbers to indicate that the
color you are looking at is not repro-
ducible with process color inks.

The Opacity option indicates the
opacity of the area below your
cursor. Rather than looking at a
single layer, the Opacity option
looks at the entire image, as though
you had merged all of the layers
together. | use this in unusual
instances, like when | work with an
image from a CAD program. These
often arrive with an opacity of
about 20%; you can’t simply
increase the opacity setting in the
Layers palette—it’s already at 100%.
So | duplicate the layer multiple
times, until I see the opacity in the
Info palette reach 100%, and then |
merge the layers together. (It’s hard
to see the difference between 95%
and 100% opacity.)

Another choice new with Photo-
shop 5.5 is Web Color. In this mode,
Photoshop will show you the
hexadecimal values of the color
under your cursor.
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Choose Web Color to display the RGB
values as hexadecimal values.

If the image is in Indexed Color
mode, Web Color will also indicate
which color in the color table is in
use (Idx). You can take a look at the
color table by choosing Image>
Mode>Color Table when you are in
Indexed Color mode. The Idx read-
out tells you the color your cursor is

on top of. It’s a bit confusing because
Photoshop designates the first color
in the palette as zero. You can also
use the Color Table dialog box to
create a file that is compatible with
the Swatches palette—just click the
Save button.
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When an image is in Indexed Color
mode, you can choose Image>Mode>
Color Table to view the color table in use.

If you forget that you can click
on the Eyedropper icons within the
Info palette, there is one more way
to change the settings for the
different readouts in the Info
palette. Choose Palette Options
from the side menu of the palette
and Photoshop will present a dialog
box for those options.
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Choose Info Options from the side
menu of the Info palette to see the
settings in use.

The only problem with the Info
palette is that it indicates the color
of the single pixel under your cursor,
which is not always terribly useful.
Sometimes you want to monitor
other areas as you adjust your image.
In Version 5.5, Adobe added a more
useful feature for the job: Color
Sampler. To access it, click on the



normal Eyedropper tool in the Tool
palette, but don’t release that mouse
just yet—if you hold the button
down, you will find a new tool hiding
under there. When you click on
your image with the Color Sampler
tool, a new readout will appear in the
Info palette! You can add up to four of
these samplers (conveniently labeled
1-4) to your image, and the Info
palette will indicate what’s currently
under them. Check this out: Choose
one of the controls under the Image>
Adjust menu and watch what
happens over in the Info palette.
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You can use up to four color samplers
at one time.

You get two sets of numbers! The
numbers on the left indicate what
was in the image before the adjust-
ment and the numbers on the right
tell you what will happen if you
actually apply the adjustment. It’s a
wonderful feature to use when color
correcting because it’s usually
exactly four areas in your image
that you adjust (highlight, shadow,
neutral gray, and flesh tone).

You can hide these color samplers
if they get in your way by choosing
Hide Samplers from the side menu
of the Info palette. You can always
bring them back by choosing Show
Samplers from the same menu.

These color samplers are even
saved in your file so you can return
to them later. When you want to rid
your document of them, then either
drag them off the edge of your screen,
or opt/alt-click on them while you
are in the Color Sampler tool.

Two final things about the color
samplers. | find | want to add them
while I’'m in the middle of an adjust-
ment, but that doesn’t work unless
you hold down the shift key while
clicking on your image. Occasionally,
I want to use the Eyedropper to
grab the color under one of the
Color Samplers, but I find it hard to
tell when they are aligned. The
solution is to press the caps lock
key to get a crosshair; you’ll know
the Eyedropper is aligned with the
Color Sampler when the cursor
disappears completely.

The Beauty of the Zero Point

As long as we’re on the topic of the
Info palette, | can’t resist a side trip to
the bottom part of the palette, even
though it doesn’t deal with describing
colors. The number in the lower left
of the Info palette indicates the
position of your cursor relative to
the “zero point” of your document.
If you haven’t messed with the rulers
yet, then the zero point is always in
the upper left corner of your docu-
ment. With default settings, | believe
the numbers are measured in inches,
but you are welcome to change the
measurement system by clicking on
the crosshair next to the numbers.
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Click on the crosshair in the lower left
of the Info palette to change the
measurement system in use.

I use inches, centimeters, points,
and picas for print work; pixels for
Web work; and percentages when I'm
dividing my image into equal areas.

Here’s a refresher course on
measurements used in publishing:
6 picas=1 inch; 1 pica=12 points;
72 points=1 inch. The publishing
industry loves this measurement
system because it doesn’t deal
with many fractions; instead, you
might hear measurements stated,
for example, as 6p3, meaning 6
picas and 3 points.

Most of the choices are self-
explanatory, but Percent can be
puzzling. This choice can tell you
the exact center of your image: Set
the measurement system to Percent,
then move your cursor until the
numbers in the Info palette read
50%—and eureka!

Back to the zero point. Turn on
the rulers by either choosing View>
Show Rulers, or by typing cmd/
ctrl-R, then clicking in the upper
left corner of the rulers where the
little dotted lines appear. Now
drag onto your image and the
zero point will be defined for
the Info palette to use. It will
tell you how far your cursor is
from the spot where you moved
the zero point. To set it back to
normal, double-click in the upper-
left corner of the rulers. The
zero point also affects where the
rulers start.
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Drag from the upper left corner of
the rulers to change the zero point
of the rulers.

Let’s check out a few tricks you
might find useful. First, double-
click on one of the rulers and see
what happens.
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Double-click on the rulers to quickly
access the Unites & Rulers settings.

That’s a quick way to change the
measurement system in use. Ok,
now click on one of the rulers and
drag onto your image—that should
give you a guide. Before you let go,
press the opt/alt key and your
guide should reverse direction
(from horizontal to vertical, etc.).
Nowy, if you haven't let go, hold
shift as you drag the guide around
the screen and it should snap to the
tick marks of the ruler.

Set the measurement system to
Percent, zoom out of your image so
there are just a few tick marks, and
now it should be pretty easy to put
guides in the center of the image.
Once you’ve placed a guide on your
image, it might take you a while to
figure out that you need to use the
Move tool to reposition it, but that
can mess you up when you’re
attempting to move a layer and
your cursor just happens to be near
a guide—you might move the guide
instead. In that case, choose Lock
Guides from the View menu so the
Move tool won't affect that guide.

You’ve got the basics, so let’s
check out some interesting features.
You can choose Snap to Guides from
the View menu (default setting),
and then when you move something
on a layer close to the guide, it will
cling to that guide. You can make
this even easier by zooming out of
your image, because Photoshop
will only have a layer cling to a
guide when it is so many screen
pixels away from the guide. The
more zoomed out you are, the
fewer screen pixels Photoshop will
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use, so the more likely that layer
will snap to something.

Let’s say you want to scale your
image up or down, but you have a
guide placed perfectly at one-half
inch away from the left edge of the
image. With default settings, the
guides would stay at the same
place relative to the content of your
picture, so if you scale down your
image 50%, the guides would be
one-quarter inch from the edge. All
you have to do is choose Lock Guides
from the View menu; then when
you scale your image up or down,
the guides will stay exactly where
they were relative to the rulers.

If you find it a bit hard to see
your guides, then choose File>
Preferences>Grids & Guides and
change the options.

Choose File>Preferences>Grids &
Guides to change the color of the
Photoshop guides.

Finally, you can choose Clear
Guides from the View menu to get
rid of all those guides.

We haven’t really finished talking
about the Info palette. The Info
palette is your best friend when it
comes to precision measurements
and definitions. The lower right
part of the Info palette is useful
when making selections because it
will indicate the width and height
in the measurement system of your
choice. Unfortunately, you cannot
type numbers into this area to
change the width and height, but
you can always choose Select>
Transform Selection, then control-
click (right mouse button in
Windows) on your image and
choose Numeric to do that.
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Choose Select>Transform Selection,
then cmd/ctrl-click and choose Numeric
to numerically transform a selection.

If you’re using the Line tool,
you’ll find a bunch of helpful info.
The numbers next to the triangles
indicate how far you’ve moved
your mouse horizontally (X) or
vertically (Y). You can find the
angle of the line (A), or it’s
length (D for distance). This
used to be of great use when you
wanted to rotate a image, but
Adobe made that much easier in
Photoshop 5.0.

Adobe added the Measurement
tool when it released Photoshop
5.0. It looks like a ruler and sits
directly above the Paint Bucket
tool in the Tools palette. It gives
you an efficient way to control
angles. In fact, that’s what | used
to rotate the text up on the
“Instant Expert” heading. With
the Measurement tool, when you
click and drag across your image
to add a measurement line, the
Info palette will pop open to show
you the angle (A) and length (D)
of the line. Then you can choose
Edit>Transform>Numeric and
Photoshop will enter the rotation
angle needed to display your layer
at the same angle as the line (it
rotates only the layer that is
active). Or, if you choose Image>
Rotate Canvas>Arbitrary (which
rotates the entire document),
Photoshop will assume your
entire document is crooked and
straighten it so the area where you
placed the measurement line will



become straight. It’s even smart
enough to check whether the line
you drew is closer to being
horizontal or vertical, and it will
rotate your image accordingly.
There is only one problem with
using the Measurement tool—after
you use it, the Info palette starts
acting like it’s spring-loaded,
popping open at odd times when
you least expect it to.

You’ll also find these numbers
showing up when you use the
Move tool to reposition a layer.
Some people use this info to move
more than one layer by the same
amount, but you can do that by
linking the layers together instead.
If you needed to move just a
portion of multiple layers, you’d
first make a selection. Then instead
of staring at the numbers in the Info
palette, choose Edit>Free Transform
(or command/control-T), then move
the layer. Now you can click on
another layer, make another selection,
and choose Edit>Transform>
Again (or shift-cmd/ctrl-T) to move
that one by the same amount. You
can even add the opt/alt key to
duplicate the info and then
transform it.

Here’s a situation where the Info
palette becomes literally essential.
What if you had two portraits and
you wanted to make sure both faces
were the same size? You could
choose the document with the
larger face, use the Marquee tool to
make a selection that starts at the
top of the subject’s head and ends
at the bottom of the chin, then
(while still using the Marquee tool),
click in the middle of that selection
and drag it on top of the second
document.

Position it so the top edge of the
selection lines up with the top of
the second head. Make sure the Info
palette is open, then choose
Select>Transform Selection and
drag the bottom edge of the

selection until it touches the second
person’s chin. Now look over at the
Info palette and the percentage
readout (H stands for height) will
tell you how much you need to
scale that picture to make the heads
the same size.

After this detailed and colorful

the free tips | provide on my Web
site at www.digitalmastery.com. <

Ben Willmore is the author of the best-
selling book Official Adobe Photoshop
5 Studio Techniques (Adobe Press)
and the founder of Digital Mastery, a
training and consulting group based

in Boulder, Colorado. Find out if Ben is
coming to your area with his “Master
Photoshop In 3 Days” seminar by
visiting www.digitalmastery.com.

lesson, let’s quit until next time.
While you’re waiting for the next
issue of PEI to arrive, check out all
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