
I’m often surprised to find that 
Photoshop users can’t describe 
the difference between the three

painting tools that they use on a
daily basis. But then again, many of
them are self-taught and are often
battling deadlines that keep them
from spending quality learning
time with the Tool palette. So in
this installment of Instant Expert,
we’re going to really get to know
Photoshop’s painting tools. And as
you might expect, there’s more
than meets the eye.

Let’s figure out the difference
between the three Photoshop
painting tools so you’ll know how
to pick the right tool for the job.
Once you know how they work,
you can give them some oomph by
combining them with other
Photoshop features. 

The Pencil 
The Pencil tool is hidden under

the Line tool in Photoshop 5.0 and
later versions. Just click and hold
on the Line tool, and you’ll see it
appear on a pop-up palette. The
Pencil is quite simple, always
delivering a hard-edged line in the
color of your current foreground.

Pencil strokes always look jagged
because the edges do not blend with
the surrounding image. If you want
to maintain a crisp look, you have to
be careful. If you scale your image

using default settings, the edge will
be smoothed out with semi-
transparent pixels. To avoid that, be
sure to use the Nearest Neighbor
setting in the Image Size dialog box
(this is how I created the edges
shown in the magnifying glasses
below). 

I use the Pencil tool when
cleaning up edges of vertical or
horizontal lines because semi-
transparent pixels are of no help in
that area. This works well for text

destined for the Web, where every
pixel counts. Also, cleaning up that
kind of line is a breeze when you
hold the shift key because it will
constrain your movement to
vertical or horizontal.

I also use the Pencil when I’m
converting an image to Bitmap

mode, which forces your image to
pure black and pure white. Because
Bitmap mode doesn’t support
many Photoshop features (filters,
adjustments, minor rotations, etc.),
it is usually preferable to work in
Grayscale mode until you are
completely finished manipulating
your image, and then convert to
reduce the file size. I’d avoid soft-
edged paint strokes with the
Paintbrush or Airbrush tools
because they will look noisy after
converting to Bitmap with default
settings. 

If you really want that noisy-
edged look, use the Paintbrush
tool, but double-click on it to open
the options palette and set the
Blending Mode pop-up menu to
Dissolve (upper left pop-up menu
in the Options palette). That way
you can see the noisy edge as you
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Left: hard-edged pencil stroke 
Right: semi-hard-edged 

paintbrush stroke

Left: un-retouched text
Right: vertical lines cleaned up

Results of 400% scaling of a hard-
edged pencil stroke using Image>
Image Size command. Left: scaled

using default setting (Bicubic) Right:
scaled using Nearest Neighbor



are painting (it will also simulate
various opacity settings using
noise). Great way to annoy co-
workers: Just slip in and change
that setting while they’re at lunch.

When editing an image that is
pure black and white, you might
get tired of changing the
foreground color back and forth
from black to white. You can do it
quickly by hitting the X key to
exchange the foreground and
background colors. But there is also
another method. The Auto Erase
checkbox in the Eraser Options
palette will instruct Photoshop to
paint with the foreground color, as
long as the color you click on is a
different from the foreground color;
otherwise it will paint with the
background color. 

Paintbrush and Airbrush
When you switch to the other

painting tools, the Brushes palette
will change to indicate that you are
no longer limited to hard-edged
brushes. It might look like you can

still use a hard-edged brush, but
these brushes always have a soft
edge (look at the first figure in this
article to see what I mean). With the
default brushes, you have the choice
of using only a semi-hard-edged
brush or a really soft one, but you
can always double-click on a default
brush to change the hardness setting.

If you choose a soft-edged brush,
you might not notice a difference
between the Paintbrush and Airbrush
tools. But if you lower the opacity,
you’ll see a world of difference. You
can paint back and forth to your
heart’s content with the Paintbrush
without getting icky paint build-up. 

However, painting with the
Airbrush is much like using a can
of real spray paint. You have to be
careful not to glob too much paint
on one area. Ok, you won’t actually
see it dripping, but if you stop
moving the mouse (but keep the
mouse button down), the paint will
accumulate until it becomes fully
opaque. That doesn’t happen when
you move the brush slowly. 

If you switch to a hard-edged
brush and keep the opacity down,
you will notice another difference
between the Paintbrush and the
Airbrush. The airbrushed paint
daubs overlap each other, but the
Paintbrush daubs do not.
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Pencil Options palette

Left: Blending Mode set to Normal
Right: Blending Mode set to Dissolve

Paintbrush Options palette

Left: Airbrush; Right: Paintbrush

Left: Airbrush; Right: Paintbrush

Brushes palette for Paintbrush 
or Airbrush tools.

Hardness settings, left to right: 100,
80, 60, 40, 20, 0

Right: Paintbrush with soft and 
hard brush

Left: Airbrush with soft and 
hard brush



That means that the Spacing
setting of the brush is more critical
with the Airbrush tool. With the
Paintbrush tool, the spacing will
determine the smoothness of the
edge of each brush stroke, whereas
with the Airbrush, the spacing
controls both the edge and how
often the paint daubs overlap each
other. (For more on the Spacing
setting, see “Photoshop Instant
Expert,” PEI November 1999.) That’s
why the Airbrush has a pressure
setting instead of an opacity
setting—they really are different.

I find myself using the Paintbrush
tool whenever I need a semi-hard-
edged line, and I switch between
the Paintbrush and Airbrush for
soft-edged lines. That way I can
lower the opacity of the tool, use a
hard-edged brush, and not have to
worry about overlapping daubs. 

If you often need to change the
opacity setting of a painting tool,
you can use the number keys. Try
it. Just press the 1 key and notice
that you get 10%; or type “23”
quickly, and you get 23%. To get
back to 100%, just type “0.” 

Make sure the Painting Cursors
preference is set to Brush Size
(File>Preferences>Displays and
Cursors), so that the cursor reflects
the brush size you have chosen. This
is the default setting in Photoshop
5.5, but not in older versions.

Back to the differences between
the Paintbrush and Airbrush tools.
The Paintbrush Options palette has

the Wet Edges feature, which will
give your soft-edged brushes a new
look. The center of your brush will
become 59% opaque and the edge
will show the full intensity of the
paint. It’s fun to create a cheap
watercolor look with this feature. 

Options in Common
These tools have many features

in common. Enter a number in the
Fade field, and you will get a brand
new look. If you start off painting
with the background color, the brush
will fade (slowly or quickly, depend-
ing on the Fade setting) to the fore-
ground color. When the brush reaches
the foreground color, it continues
with that color until you release the
mouse button. There are actually
two choices when using fade: Fade to
Background, or Fade to Transparent.

The Fade number is not measured
in pixels, picas, or inches, but in

paint daubs. Let’s take a quick
refresher in using Photoshop
brushes. Double-click on the active
brush in the Brushes palette,
change Spacing to 110, and paint
on your image. 

Now experiment with the Fade
setting, trying 5, then 12, then 25,
and count how many daubs it takes
until the color fades to your
foreground color. 

The default brush spacing setting
is 25%, which means the daubs are
spaced 25 percent of the width of
your brush. This can create big
problems when painting with
large, hard-edged brushes because
there will be lumps on the edges.
You’d usually lower the spacing to
1% in that case, but 25% seems to
be fine for soft-edged brushes. 

You’ll need to experiment with
Spacing and Fade settings to get
what you want. For a less flat-
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Airbrush with Pressure=30% and
Spacing settings=1%, 25%, 

50%, and 75%.

Choose File>Preferences>Displays
and Cursors and set the Painting

Cursors setting to Brush Size.
The Spacing setting determines how
far your brush moves before placing

the next paint daub on the image.

Left: normal soft-edged brush
Right: Paintbrush set to Wet Edges

Fade settings from top to bottom: 
5, 12, 25

Left: default Spacing (25%)
Right: Spacing 1%

Left: Fade to Transparent
Right: Fade to Background



looking image, I use Fade only
when my foreground and
background colors are very similar
(like red and orange).

I don’t use the Fade setting often,
but then again, I use a pressure-
sensitive Wacom graphics tablet. I
can turn on the Stylus checkboxes
and go creative. Just turning on the
Color checkbox gives you immense
control. You can use light pressure
to get the background color, and as
you press harder and harder, the
color will become closer to the
foreground color. That gives you
much more creative control than
the simple Fade setting. 

While we’re on the topic of
graphics tablets: You can turn on
the Opacity checkbox so that light
pressure will give you low opacity
and higher pressure will give you
what you have specified in the
Options palette. The Size checkbox
will allow you to control brush size
by varying pressure on the pen.
Light pressure will produce a very
small brush, and hard pressure will
give you the brush size you have
chosen in the Brushes palette.
There are similar options in most of
Photoshop’s retouching tools.

Don’t fret if you don’t have a
graphics tablet. You can option/alt-
click on an image when using any
of the painting tools to temporarily
access the Eyedropper tool. This
allows you to click on the image
and change the color you are
painting with, or you can always
click in the Swatches palette for a
quick color change.

Nifty Features 
Now let’s move beyond the

“normal” options and throw in some
fun ones. Try this: Create a new layer,
paint on it, and then switch the fore-
ground color. Set the Blending mode
of your Paintbrush tool (pop-up
menu in the upper left of the Options
palette) to Behind and paint again.
This limits your painting to the empty
parts of the active layer, as if you
were painting on an underlying layer. 

Get the opposite effect by turning
on the Preserve Transparency check-
box at the top of the Layers palette.
But don’t turn on both options at
once or you won’t be able to paint
anywhere in your image. 

Sometimes you want to add paint
to an image, but you don’t want it
to completely replace the image.
Instead, you might want it to look
like a magic marker. To accomplish
this, set the Blending mode of your
painting tool to Multiply. 

Let’s see what else we can come
up with. Well, you can change the
Blending Mode menu to Hue to
change the color of objects in the
image. Just try that when painting
over an image of a car. You can only
change the color of things that
already contain color. 

To add color to a grayscale
image, first change the mode to
RGB, then paint with the Blending
mode set to Color or Color Burn.
You can also lower the opacity 
to apply it with less intensity. 

If you want to turn part of an image
into grayscale, leaving the rest in
color, then paint with black and set
the Blending Mode to Saturation.

Eraser Tool
In many ways, the Eraser tool is

like the painting tools. It even has a
pop-up menu that lets you tell
Photoshop whether you want the
Eraser to act like the Pencil (hard
edges), Paintbrush (soft with non-
overlapping strokes), Airbrush (soft
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Top: Size checkbox turned on
Middle: Opacity checkbox turned on
Bottom: Color checkbox turned on

Left: paint stroke set to Normal mode
Right: second paint stroke 

using Behind mode

Left: Paintbrush tool set to Normal
Right: Paintbrush tool set to Hue

Left: Paintbrush tool set to Normal
Right: Paintbrush tool set to Color

Left: Paintbrush tool set to Normal
Right: Paintbrush tool set to Saturation

Left: green paint stroke, 
Right: same paint stroke using

Preserve Transparency

Left: Paintbrush tool set to Normal
Right: Paintbrush tool set to Multiply



with overlapping strokes), or the
old square block one you were
forced to use in Photoshop 2.5
unique to the block Eraser is that it
doesn’t change size when you
zoom in to your image. My
preference is usually Paintbrush. 

The Eraser tool has two ways of
working on your image, depending
on what you are feeding it. If you
are working on the background
layer, that’s special—you can’t
poke a hole in the background, so
Photoshop just paints with the
background color. But there is
nothing to stop you from double-
clicking on the background layer
and converting it into a normal
layer. Then the Eraser tool will
actually erase. 

The Eraser even has an opacity
setting so you can leave a residue
of elements from a layer. 

To erase a large area, I usually
make a selection and press the
delete key instead of using the
Eraser tool. How can you partially
delete a large area? It’s easy if you
know about an unusual option.

Instead of pressing delete, try shift-
delete. This will bring up the Fill
dialog box (I know this keyboard
shortcut isn’t listed in the menu,
but it works). Now set the Blending
mode to Clear and lower the
Opacity setting, which does the
same thing as using the Eraser tool
with a lower opacity setting.

Now let’s take a look at one
more nifty option with the Eraser
tool. It’s what most people call the
“magic eraser.” You can get to it by
either turning on the Erase to History
checkbox, or holding down the
option/alt key while using the
Eraser tool. That should restore the
appearance of your image to the
way it was when you first opened
it. Unless, that is, you’ve changed
the settings in the History palette. I
like to use this option in
combination with the opacity
setting to blend the original image
with the current one.

OK, one more trick: Hold the
shift key and click in multiple
places (release the mouse button
between clicks), and Photoshop
will connect the dots with nice
straight lines.

The Line Tool
If you truly want to draw

straight lines (instead of erasing
with them), then switch to the Line
tool—that’s what it’s designed for.
You can specify the exact width of
the line and just click and drag to
see a preview, which is often more
helpful than that last tip. You can

also hold the shift key while using
the tool to constrain the line you are
making to an increment of 45 degrees. 

If you really prefer the round-
edged look you get with a painting
tool to the flat edge you get with
the Line tool, just choose
Filter>Noise>Median and play
with the slider to round the edges
of the line you’ve made.

You can even add arrowheads
(but no tail feathers) to your lines.
Just turn on the Start or End
checkboxes (or both). You can
specify the shape of the
arrowheads by changing the
settings under the Shape button.

The Width setting determines
the width of the back of the arrow-
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Eraser Options palette

Eraser Options palette

Use the Median filter to round 
the corners.

The Arrowhead Shape options 
dialog box.

Use the Clear Blending mode and
lower the Opacity setting to partially

erase an area.

Left: Paintbrush using 70% opacity
Middle: Paintbrush using 

100% opacity
Right: Eraser using 30% opacity



head compared to the width of the
line itself (that’s why it’s a
percentage). 

The Length setting determines
how long the arrowhead will be
relative to the width of the line. 

And finally, the Concavity
setting determines the angle of the
lines that make up the back of the
arrowhead. If you were to connect
the lines that make up the back of
the arrowhead, this setting would
determine how far along the length
of the arrowhead that intersection
will appear. You can even set it to a
negative number (up to -50) to
yield a diamond shape. But if you
don’t drag far enough, you might

get an arrowhead without a line
coming out of it, so be careful.

I use arrowheads a lot when
creating maps in Photoshop, but 
I don’t always like the sharp
edges. You can round those 
sharp-edged corners by choosing
Filter>Noise>Median.

You can even open the Info
palette to find out the length of the
line you are making (D, for
distance) or the angle of the line
(A). The numbers next to the
triangles indicate how far you have
dragged horizontally (X) and
vertically (Y). This information can

be immensely useful when you add
particular filters. Example:
Remember the angle setting and
then use that when applying the
Motion Blur filter.

If you want a multi-colored 
line (with or without arrowheads),
just be sure the arrow is on its 
own layer, then turn on the

Preserve Transparency checkbox 
at the top of the Layers palette 
and use the Gradient tool to 
add color.

Paint Bucket Tool
Since we’re talking about ways

to add color to your images, we
can’t forget about the Paint Bucket
tool, which is closely related to the
Magic Wand tool. In fact, it does
the exact same thing as clicking
with the Magic Wand and then
typing option/alt-delete to fill the
selected area with the foreground
color. I prefer to do it that way
because then I can always modify
the selection before filling it, and
keep much more control. 

And just like the Magic Wand
tool, the Paint Bucket has a
tolerance setting that determines
how wide a range of colors it
should fill, based on the color you
click on. A tolerance of 10 will fill
areas that are 10 shades brighter or
darker than the shade you click
on. The Tolerance setting can
range from 0 to 255 because you
can have up to 256 shades of gray
in any image. 
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Width settings from left to right: 
250%, 500%, 1,000%

The Info palette will indicate the
length (D) and angle (A) of the line

being made.

Paintbucket Options palette

Measurements in the Info palette can
be useful when applying filters.

Left: original
Right: Preserve Transparency used

with the Gradient tool

Length settings from left to right: 
250%, 500%, 1,000%

Concavity settings from top to bottom: 
50%, 0%, -50%

Right: really short lines
Left: longer lines



Brighter/Darker Tolerance
0% 0
10% 26
20% 51
30% 77
40% 102
50% 128
60% 153
70% 179
80% 204
90% 230
100% 255

You also have the choice of
filling the area with the foreground
color (the default setting) or with a
pattern. (We’ll discuss patterns in a
future installment.)

If you are using default settings,
then the Paint Bucket tool will 
be able to work on only the
information on the active layer. If
you would like for it to see all of
the layers, turn on the Use All
Layers checkbox. When that option
is turned on, the tool will see all the
layers, but it will be able to fill only
the active layer.

With Photoshop 5.5, Adobe
added the Contiguous option. With
this option turned on, the Paint
Bucket can fill only the areas that
touch each other. Turn off
Contiguous, and it will find any
occurrence of the color you click
throughout the document.

You can use the Paint Bucket
tool to delete areas—really, you
can. Just change the Blending
mode of the Paint Bucket tool to
Clear, and you have an eraser just
like the new Magic Eraser that

comes with Photoshop 5.5.
There are two more special

options I’d like to share. You can
hold down the option/alt key
when using the Paint Bucket Tool
to temporarily access the
Eyedropper tool, so you can
quickly change the foreground
color without having to switch
tools. You can also press the caps
lock key to change the cursor into a
crosshair, allowing you to see
exactly where you are clicking.

OK. I think I’ve filled your
heads with enough info on the
painting tools, all of which will
become much more significant and
interesting when we move on to
Photoshop’s more advanced
features, like Layer Masks. While
you’re waiting for the next issue of
PEI to arrive, check out all the free
tips I provide on my Web site at
www.digitalmastery.com. §

Ben Willmore is the author of the best-
selling book Official Adobe Photoshop
5 Studio Techniques (Adobe Press)
and the founder of Digital Mastery, a
training and consulting group based
in Boulder, Colorado. Find out if Ben is
coming to your area with his seminar,
“Master Photoshop in 3 Days,” by
visiting www.digitalmastery.com.
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Tolerance settings from top to bottom:
10, 30, 70, 150
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